Problem 1003

Problem 1003

Time Limit: 1 Sec   Memory Limit: 64 MB
Submit: 94   Solved: 27
[ Submit][ Status][ Web Board]

Description

字符串的输入输出处理。

Input

第一行是一个正整数N,最大为100。之后是多行字符串(行数大于N), 每一行字符串可能含有空格,字符数不超过1000。

Output

先将输入中的前N行字符串(可能含有空格)原样输出,再将余下的字符串(不含有空格)以空格或回车分割依次按行输出。每行输出之间输出一个空行。

Sample Input

2www.njupt.edu.cn NUPTA C MN U P Ter

Sample Output

www.njupt.edu.cn NUPTA C MNUPTer

#include<iostream>
#include<string.h>
#include<ctype.h>
using namespace std;
int main()
{
	int n,i;
	char a[1000];
	string b;
	cin>>n;
    while(n-->=0)
	{
		gets(a);
		if(strlen(a))
		{
			cout<<a<<endl<<endl;
		}
	}
	while(gets(a))
	{
		
		if(strlen(a))
		{
			for(i=0;i<strlen(a);i++)
			{
				if(a[i]!=' ')
					cout<<a[i];
				else if(a[i]==' ')
					cout<<endl<<endl;
			}
			cout<<endl<<endl;
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值