A1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1   

题目大意:

输入整数n,b,将十进制数n转化为b进制数x之后判断是否为回文数(正反写相同),是则输出Yes反之No,最后倒序输出x;

所有一位数均为回文数;

思路:

先将n转化为b进制数x,之后写一循环第一个数对应最后一个数,依次类推,判断是否为回文数;

注意查看是否囊括x只有一位的情况;

代码如下:

#include <cstdio>

bool judge (int ns[], int count) {				//写一函数判断; 
	for (int i = 0; i <= count / 2; i++) {
		if (ns[i] != ns[count - 1 - i])	{
			return false;
			break;
		}
	}
	return true;
}

int main()
{
	int n, b, ns[35];
	int count = 0;
	scanf ("%d %d", &n, &b);
	do {
		ns[count++] = n % b;
		n = n / b;
	}	while (n != 0);
	
	bool flag = judge (ns, count);
	if (flag == true)		printf ("Yes\n");
	else 					printf ("No\n");
	
	for (int i = count - 1; i >= 0; i--) {		                //倒序输出; 
		printf ("%d", ns[i]);
		if (i != 0)		printf (" ");
		else  	printf ("\n");
	}

 	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值