求绝对值最大值 -java求绝对值

Problem Description

求n个整数中的绝对值最大的数。

Input

输入数据有2行,第一行为n,第二行是n个整数。

Output

输出n个整数中绝对值最大的数。

Sample Input

5
-1 2 3 4 -5

Sample Output

-5

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in);
         int a = input.nextInt();
         int i;
         int h[]=new int[a];
         for(i=0;i<a;i++)
         {
             h[i] = input.nextInt();
         }
         int f = h[0];
         for(i=0;i<a;i++)
         {
             if(Math.abs(h[i])>Math.abs(f))f=h[i];
         }
         System.out.println(f);
          input.close();
    }
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值