java实验--求绝对值最大值

Problem Description

求n个整数中的绝对值最大的数。

Input

输入数据有2行,第一行为n,第二行是n个整数。

Output

输出n个整数中绝对值最大的数。

Sample Input

5
-1 2 3 4 -5

Sample Output

-5

注:

java中没有fabs函数。

import java.util.Scanner;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int a[] = new int [n];
		int b[] = new int [n];
		for(int i = 0; i < n; i++){
			a[i] = sc.nextInt();
			if (a[i] < 0) b[i] = -a[i];
			else b[i] = a[i];
		}
		int i, m = 0; max = b[0];
		for(i = 1; i < n; i++){
			if (b[i] > max){
				max = b[i];
				m = i;
			}
		}
		System.out.println(a[m]);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值