数据结构上机测试4.1:二叉树的遍历与应用1

Problem Description

输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。

Input

第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。

Output

输出该二叉树的后序遍历序列。

Sample Input

ABDCEF
BDAECF

Sample Output

DBEFCA

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data;
    struct node *left,*right;
};
struct node *creat(int n,char *str1,char *str2)
{
    struct node *root;
    int i;
    if(n==0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=str1[0];
    for(i=0; i<n; i++)
    {
        if(str2[i]==str1[0])
            break;
    }
    root->left=creat(i,str1+1,str2);
    root->right=creat(n-i-1,str1+i+1,str2+i+1);
    printf("%c",root->data);
    return root;
};
int main()
{
    int n;
    char str1[1100],str2[1100];
    scanf("%s",str1);
    scanf("%s",str2);
    n=strlen(str1);
    creat(n,str1,str2);
    printf("\n");
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值