思维 Ball

Jenny likes balls. He has some balls and he wants to arrange them in a row on the table. 
Each of those balls can be one of three possible colors: red, yellow, or blue. More precisely, Jenny has R red balls, Y yellow balls and B blue balls. He may put these balls in any order on the table, one after another. Each time Jenny places a new ball on the table, he may insert it somewhere in the middle (or at one end) of the already-placed row of balls. 
Additionally, each time Jenny places a ball on the table, he scores some points (possibly zero). The number of points is calculated as follows: 
1.For the first ball being placed on the table, he scores 0 point. 
2.If he places the ball at one end of the row, the number of points he scores equals to the number of different colors of the already-placed balls (i.e. expect the current one) on the table. 
3.If he places the ball between two balls, the number of points he scores equals to the number of different colors of the balls before the currently placed ball, plus the number of different colors of the balls after the current one. 
What's the maximal total number of points that Jenny can earn by placing the balls on the table?
Input
There are several test cases, please process till EOF. 
Each test case contains only one line with 3 integers R, Y and B, separated by single spaces. All numbers in input are non-negative and won't exceed 10  9.
Output
For each test case, print the answer in one line.
Sample Input
2 2 2
3 3 3
4 4 4
Sample Output
15
33
51

题意:

3种颜色的球,放成一列

1.对于第一个放在桌子上的球,他得分为0分。

2.如果他将球放在排的一端,他得分的点数等于已经放置的球的不同颜色的数量(即期望当前的球数)在桌子上。
3.如果他把球放在两个球之间,他得分的点数等于当前放置的球之前的球的不同颜色的数量,加上当前球之后的球的不同颜色的数量。

让你算最后得分最大值。

思路:

列举一些情况后,发现其中得分情况无非6种:

0 1 

0 1 2...

0 1 2 3 ...

0 1 2 3 4...

0 1 2 3 4 5...

0 1 2 3 4 5 6...

...后的值是一行最后那个值

然后就要分情况讨论了

我们发现,当一个颜色的球数量大于2时,每一次他最多贡献2个得分,如果数量小于2,那么有几个就能贡献多少分。

然后以此为条件判断,注意long long就行了

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
    long long  a,b,c;
    {
        while(scanf("%lld%lld%lld",&a,&b,&c)!=-1)
        {   long long d=a+b+c;
            int ans=0;
            long long sum=0;
            if(a>=2&&b>=2&&c>=2)
                sum=15+(d-6)*6;
            else
            {
                if(a>=2)
                {
                    ans+=2;
                    d-=2;

                }
                else
                {
                    ans+=a;d-=a;
                }
                if(b>=2)
                {
                    ans+=2;
                    d-=2;
                }
                 else
                {
                    ans+=b;d-=b;
                }
                if(c>=2)
                {
                    ans+=2;
                    d-=2;
                }
                 else
                {
                    ans+=c;d-=c;
                }
                sum=(ans+1)*ans/2+(d-1)*ans;

            }
           printf("%lld\n",sum);
        }
    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值