5934: Hoofball(思维题)

5934: Hoofball

时间限制: 1 Sec   内存限制: 128 MB
提交: 186   解决: 34
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

In preparation for the upcoming hoofball tournament, Farmer John is drilling his N cows (conveniently numbered 1…N, where 1≤N≤100) in passing the ball. The cows are all standing along a very long line on one side of the barn, with cow ii standing xi units away from the barn (1≤xi≤1000). Each cow is standing at a distinct location.
At the begiNing of the drill, Farmer John will pass several balls to different cows. When cow i receives a ball, either from Farmer John or from another cow, she will pass the ball to the cow nearest her (and if multiple cows are the same distance from her, she will pass the ball to the cow farthest to the left among these). So that all cows get at least a little bit of practice passing, Farmer John wants to make sure that every cow will hold a ball at least once. Help him figure out the minimum number of balls he needs to distribute initially to ensure this can happen, assuming he hands the balls to an appropriate initial set of cows.

输入

The first line of input contains N. The second line contains N space-separated integers, where the ith integer is xi.

输出

Please output the minimum number of balls Farmer John must initially pass to the cows, so that every cow can hold a ball at least once.

样例输入

5
7 1 3 11 4

样例输出

2

提示

In the above example, Farmer John should pass a ball to the cow at x=1 and pass a ball to the cow at x=11. The cow at x=1 will pass her ball to the cow at x=3, after which this ball will oscillate between the cow at x=3 and the cow at x=4. The cow at x=11 will pass her ball to the cow at x=7, who will pass the ball to the cow at x=4, after which this ball will also cycle between the cow at x=3 and the cow at x=4. In this way, all cows will be passed a ball at least once (possibly by Farmer John, possibly by another cow).

It can be seen that there is no single cow to whom Farmer John could initially pass a ball so that every cow would eventually be passed a ball.

来源

USACO 2018 February Contest, Bronze 

N头牛进行传球,最后总会在两头牛之间进入循环,找到每个循环,如果此循环的左边和右边都有外来的球,说明会有两个球进入此循环,否则只有一个(包括第一个点和最后一个点)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    long long n, a[110], flag[110], vis[110], next[110];
    memset(flag, 0, sizeof(flag));
    memset(vis, 0, sizeof(vis));
    scanf("%lld", &n);
    for(int i=1;i<=n;i++)
        scanf("%lld", &a[i]);
    if(n==1 || n==2)
    {
        printf("1\n");
        return 0;
    }
    sort(a+1, a+n+1);
    for(int i=1;i<=n;i++)
    {
        if(i==1)
            next[i]=2;
        else if(i==n)
            next[i]=n-1;
        else
        {
            if(a[i]-a[i-1]<=a[i+1]-a[i])
                next[i]=i-1;
            else
                next[i]=i+1;
        }
    }
    for(int i=1;i<=n;i++)
        if(next[next[i]]==i)
            flag[i]=1;
    long long ans=0;
    for(int i=1;i<=n;i++)
        if(flag[i] && flag[i+1] && !vis[i] && !vis[i+1])
        {
            if(i>1 && i<n && next[i-1]==i && next[i+2]==i+1)
                ans+=2;
            else
                ans+=1;
            vis[i]=vis[i+1]=1;
        } 
    printf("%lld\n", ans);  
    return 0;
} 
/**************************************************************
    Problem: 5934
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:0 ms
    Memory:1096 kb
****************************************************************/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hhjian6666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值