1075. PAT Judge (25)

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
又是一道很绕的题目;
首先能输出的人要求不能没有提交过一道题目或者没有一道通过编译;
然后显示'-'表示没有提交过,提交了没有通过编译表示0分如Sample Output的00005第二题输出是0

最后理清思路后写完还是测试点4错误,才发现提交不能通过编译的不能直接把他设为0分,要先判断之前有没有提交过
有分数的,hh也对,可能一开始做出来,后面很心急提交结果编译错误

#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
#define MAX 10005

using namespace std;

struct stu{
    int total;
    int id;
    int perfect;
    vector<int> problem;
    stu():total(-1), id(-1), perfect(0), problem(6, -1){};
};

stu s[MAX];

bool cmp(const stu &a, const stu &b)
{
    if(a.total != b.total)
        return a.total > b.total;
    else if(a.perfect != b.perfect)
        return a.perfect > b.perfect;
    return a.id < b.id;
}
int main()
{
    int n, k, m;
    int score[6];
    int id, p, grade;
    scanf("%d %d %d", &n, &k, &m);
    for(int i=1; i<=k; i++)
    {
        scanf("%d", &score[i]);
    }
    for(int i=0; i<m; i++)
    {
        scanf("%d %d %d", &id, &p, &grade);
        if(grade != -1)//成功提交能通过编译的
        {
            if(s[id].total == -1)//修改总分标记通过编译
                s[id].total = 0;
            s[id].id = id;
            s[id].problem[p] = max(grade, s[id].problem[p]);//取分数较大的
        }
        else{
            if(s[id].problem[p] < 0)//测试点4
                s[id].problem[p] = 0;//没通过编译但是提交了为0分
        }
    }
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=k; j++)
        {
            if(s[i].total == -1)//没通过编译的或没提交过的不统计
                break;
            if(s[i].problem[j] != -1)//没提交的不计分
            {
                s[i].total += s[i].problem[j];
                if(s[i].problem[j] == score[j])//满分则计数
                    s[i].perfect++;
            }
        }
    }
    sort(s+1, s+n+1, cmp);//排序
    int currank = 1;
    for(int i=1; i<=n; i++)
    {
        if(s[i].total == -1)
            break;
        if(i!=1 && (s[i].total != s[i-1].total))
            currank = i;
        printf("%d %05d %d", currank, s[i].id, s[i].total);
        for(int j=1; j<=k; j++)
        {
            if(s[i].problem[j] != -1)
            {
                printf(" %d", s[i].problem[j]);
            }
            else{
                printf(" -");
            }
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值