1076. Forwards on Weibo (30)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

BFS,当广度超过给定值的时候就停止搜索,注意的是存图时候给出的是这个人关注的对象,而存贮的应该是user被follow的对象,因为你发的消息往下搜索应该是follow你的人

#include <iostream>
#include <vector>
#include <iterator>
#include <queue>
#include <cstring>
#include <utility>
#define MAX 1005
using namespace std;

struct user{
    vector<int> followed;
};

user graph[MAX];
bool visit[MAX];
int N, L;
void init()
{
    int num, temp;
    for(int i=1; i<=N; i++)
    {
        cin >> num;
        for(int j=0; j<num; j++)
        {
            cin >> temp;
            graph[temp].followed.push_back(i);
        }
    }
}

void BFS(int x)
{
    int counter = 0, level = 0, curlevel = 0;
    queue<pair<int, int> > myque;
    vector<int>::iterator it;
    visit[x] = true;
    myque.push(make_pair(x, level));
    while(!myque.empty())
    {
        pair<int, int> temp = myque.front();
        myque.pop();
        if(curlevel < temp.second)
        {
            curlevel = temp.second;
        }
        if(curlevel+1 > L)
            break;
        for(it=graph[temp.first].followed.begin(); it!=graph[temp.first].followed.end(); it++)
        {
            if(!visit[*it])
            {
                visit[*it] = true;
                myque.push(make_pair(*it, curlevel+1));
                counter++;
            }
        }
    }
    cout << counter << endl;
}

int main()
{
    int n, temp;
    cin >> N >> L;
    init();
    cin >> n;
    while(n--)
    {
        memset(visit, false, sizeof(bool)*(N+1));
        cin >> temp;
        BFS(temp);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值