PAT-1076. Forwards on Weibo (30)

本文介绍了如何解决PAT中的1076题——微博转发问题,探讨了使用深度优先搜索(DFS)算法在限制间接关注者层数的情况下,计算某个用户能引发的最大转发潜力。关键在于邻接表存储图,以及注意题目要求的特殊建表方式和计数策略。
摘要由CSDN通过智能技术生成

<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">消失了好久。。我又回来了...</span>

继续PAT,今天终于做了道30分的题目。。发现c++还是比java好写啊,而且提交的时候终于不用担心超时了


为了突出重点,把题目放到最后把。今天主要是一道DFS的题。

思路如下:

1,邻接表存储图;

2,应用深度优先搜索,但是有深度的限定。

要注意:

①题目所给的形式不能直接建表,要反过来建;

②计数的时候除了设定visited[]数组标记是否访问,还要设定bAdded[]数组标记是否计算过。


题目:

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5


先贴个DFS的伪代码吧:

void DFS(node** graph, int num, bool visited[])
{
    node* pNode = pGraph[num];
	visited[pNode->num] = true;
        cout << pNode->num;
	while(pNode->next != NULL)
	{
		pNode = pNode->next;
		if(!visited[pNode->num])
		{
			DFS(pGraph, pNode->num, visited);
		}
	}
	return res;
}

通过的代码,泪流满面,已经很久没有AC了。。。

#include <iostream>
using namespace std;

struct node
{
	int num;
	node* next;
};

int DFS(node** pGraph, int num, int depth, bool visits[], bool added[])
{
	int res = 0;
	if(depth <= 0)
		return (int)visits[num];
	node* pNode = pGraph[num];
	visits[pNode->num] = true;
	while(pNode->next != NULL)
	{
		pNode = pNode->next;
		if(!visits[pNode->num])
		{
			if(!added[pNode->num])
			{
				res++;
				added[pNode->num] = true;
			}
			res = res + DFS(pGraph, pNode->num, depth-1, visits, added);
		}
	}
	return res;
}

//赋初始值false , 起点赋值true
void Initial(int count, bool visited[], bool added[], int start)
{
	for(int i = 1; i <= count; i ++)
	{
		visited[i] = false;
		added[i] = false;
		if(i == start)
		{
			visited[i] = true;
			added[i] = true;
		}
	}
}

int main()
{
	int count, max, resCount;
	cin >> count >> max;
	node* graph[1001];
	bool visited[1001];
	bool added[1001];
	node* follower;
	int nFowNum = 0;
	int tempNum = 0;
	for(int i = 1; i <= count; i ++)
	{
		
		node* user = new node();
		user->num = i;
		graph[i] = user;
	}
	for(int i = 1; i <= count; i ++)
	{
		node* pNode;
		
		nFowNum = 0;
		cin >> nFowNum;
		for(int j = 0; j < nFowNum; j ++)
		{
			node* fow = new node();
		    fow->num = i;
		    fow->next = NULL;
			cin >> tempNum;
			pNode = graph[tempNum];
			while(pNode->next != NULL)
			{
				pNode = pNode->next;
			}
			pNode->next = fow;
		}
		
	}

	cin >> resCount;
	for(int k = 0; k < resCount; k ++)
	{
		int resNum;
		cin >> resNum;
		Initial(count, visited, added, resNum);
		cout << DFS(graph, resNum, max, visited, added) << endl;
	}

	//释放内存
	for(int i = 1; i <= count; i ++)
	{
		node* pNode = graph[i];
		node* pDel;
		if(pNode == NULL)
			continue;
		while(pNode->next != NULL)
		{
			pDel = pNode;
			pNode = pNode->next;
			delete pDel;
		}
		delete pNode;
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值