1034. Head of a Gang (30)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:
8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 1:
2
AAA 3
GGG 3
Sample Input 2:
8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10
Sample Output 2:
0

并查集,用的很少,

一开始以为路径压缩版Union之后一个集合的所有元素都指向根,但实际并不是这样,例如0和1 Union得到pre[0] = 1, 然后1和2 Union得到pre[1] = 2

此时0的根还是1 所以最后求某元素的根需要用Find(x)而不是pre[x],也可以在所有union完成后对所有元素进行一次Find即路径压缩就可以用pre[x],

另外一个问题就是N条记录最大可能人数有2N


#include <iostream>
#include <map>
#include <string>
#include <utility>
#include <iterator>
#include <vector>
#define MAX 2005
using namespace std;
int pre[MAX];
map<string, int> name_key;
map<string, int> name_time;
map<string, int> per_time;
string key_name[MAX];
int N, Time, counter = 0;
int Find(int x)
{
    return pre[x]==x ? x : pre[x]=Find(pre[x]);
}

void Union(int x, int y)
{
    int u = Find(x);
    int v = Find(y);
    if(u == v)
        return ;
    pre[u] = v;
}

void init()
{
    int t;
    string n1, n2;
    cin >> N >> Time;
    for(int i=0; i<2*N; i++)//最多可能人数有2倍
    {
        pre[i] = i;
    }
    for(int i=0; i<N; i++)
    {
        cin >> n1 >> n2 >> t;
        if(name_key.find(n1) == name_key.end())
        {
            name_key[n1] = counter;
            key_name[counter] = n1;
            counter++;
        }
        if(name_key.find(n2) == name_key.end())
        {
            name_key[n2] = counter;
            key_name[counter] = n2;
            counter++;
        }
        Union(name_key[n1], name_key[n2]);
        name_time[n1] += t;//记录每条通话时间
        per_time[n1] += t;//记录个人总时间
        per_time[n2] += t;
    }

}
int main()
{
    int total[MAX] = {0};
    int count[MAX] = {0};
    map<string, int> head_num;
    init();
    for(int i=0; i<counter; i++)
    {
        total[Find(i)] += name_time[key_name[i]];//每个集合的总通话时间,记录在该集合的根上
        count[Find(i)]++;//每个集合的人数
    }
    for(int i=0; i<counter; i++)
    {
        if(count[i] > 2 && total[i] > Time)//当该点即某集合的满足条件是找到该集合的head
        {
            int w = -1;
            string head;
            for(auto it=per_time.begin(); it!=per_time.end(); it++)
            {
                if(Find(name_key[it->first]) == i && it->second > w)
                {
                    head = it->first;
                    w = it->second;
                }
            }
            head_num[head] = count[i];
        }
    }
    cout << head_num.size() << endl;
    for(auto it=head_num.begin(); it!=head_num.end(); it++)
    {
        cout << it->first << " " << it->second << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值