HDU - 2601 An easy problem

An easy problem

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10698    Accepted Submission(s): 2728


 

Problem Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..


One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

 

 

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^10).

 

 

Output

For each case, output the number of ways in one line.

 

 

Sample Input

 

2 1 3

 

 

Sample Output

 

0 1

 

 

Author

Teddy

 

 

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2600 2603 2606 2605 2546 

 

 

 

题意:给n 求满足i*j+i+j=n(0<i<=j)方案数

思路:xy+x+y=n
          (x+1)(y+1)=x*y+x+y+1=n+1;

          即求n+1的因子对数

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main()
{
	int t;scanf("%d",&t);
	while(t--)
	{
		LL n;
		scanf("%lld",&n);
		n++;
		int m=sqrt(n);
		int ans=0;
		for(int i=2;i<=m;i++)
		{
			if(n%i==0)ans++;
		}
		printf("%d\n",ans);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值