HDU-2601 Bone Collector(DP 01背包)

24 篇文章 0 订阅
10 篇文章 0 订阅

HDU-2601 Bone Collector(DP 01背包)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

题意:经典的01背包问题,状态方程:
dp[i][j] = max(dp[i-1][j] , dp[i-1][ j-vol[i] ] +val[i] )
不过要考虑体积为零的情况,所以一直WA了
3
3
3 3 3
0 1 0
ans:6

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
#define pi 3.14159265359
typedef long long LL;
const int maxn = 1100;
int n, m, k;
int dp[maxn][maxn],vol[maxn],val[maxn];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++){
            scanf("%d",&val[i]);
        }
        for(int i=1; i<=n; i++){
            scanf("%d",&vol[i]);
        } 
        for(int i=1; i<=n; i++){
            for(int j=m; j>=0; j--){
                    if(j>=vol[i])
                        dp[i][j] = max(dp[i-1][j],dp[i-1][j-vol[i]] +val[i] );
                    else //小于包的情况
                        dp[i][j] = dp[i-1][j]; 
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}

法二:节约空间,一维dp可以 i层 覆盖掉 i-1层 的情况,即dp[ j-vol[i] ]保存的是dp[i-1层][ j-vol[i] ]

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
#define pi 3.14159265359
typedef long long LL;
const int maxn = 1100;
int n, m, k;
int dp[maxn],vol[maxn],val[maxn];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++){
            scanf("%d",&val[i]);
        }
        for(int i=1; i<=n; i++){
            scanf("%d",&vol[i]);
        } 
        for(int i=1; i<=n; i++){
            for(int j=m;j>=vol[i];j--){// 覆盖i-1
                dp[j] = max(dp[j],dp[j-vol[i]] + val[i] );
                //cout<<i<<" "<<j<<" "<<dp[j]<<endl;
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值