poj 3083 Children of the Candy Corn dfs+bfs

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9
题意:给出一个迷宫,求出始终沿着左边墙走出去时间,始终沿着右边墙走走出去时间以及任意走最短时间。

思路:左右走分别dfs,任意走bfs。

代码:

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define maxn 50

char s[maxn][maxn];
int h,w;
int dx[] = {-1,0,1,0};
int dy[] = {0,1,0,-1};
struct Node{
	int x,y;
	int dir;  // 0 1 2 3 :  up right down left
	int step;
	Node(){}
	Node(int a,int b,int c):x(a),y(b),step(c){}
}start,stop;

int bfs(){
	Node node;
	bool v[maxn][maxn];
	memset(v,false,sizeof v);
	queue<Node> que;
	que.push(start);
	v[start.x][start.y] = true;
	while(!que.empty()){
		node = que.front();
		que.pop();
		if(node.x==stop.x && node.y==stop.y) return node.step;
		
		for(int i=0;i<4;i++){
			int xx = node.x+dx[i], yy = node.y+dy[i];
			if(xx>=0 && xx<h && yy>=0 && yy<w && s[xx][yy]!='#' && !v[xx][yy]){
				v[xx][yy] = true;
				que.push(Node(xx,yy,node.step+1));
			}
		}
	}
	return 0;
}

int dfs_left(int x,int y,int dir,int step){
	if(x==stop.x && y==stop.y) return step;
	
	int xx,yy;
	int dir1 = (dir-1+4)%4;
	xx = x+dx[dir1], yy = y+dy[dir1];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir1,step+1);
	
	int dir2 = dir;
	xx = x+dx[dir2], yy = y+dy[dir2];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir2,step+1);
	
	int dir3 = (dir+1)%4;
	xx = x+dx[dir3], yy = y+dy[dir3];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir3,step+1);
	
	int dir4 = (dir+2)%4;
	xx = x+dx[dir4], yy = y+dy[dir4];
	if(s[xx][yy]!='#') return dfs_left(xx,yy,dir4,step+1);
}

int dfs_right(int x,int y,int dir,int step){
	if(x==stop.x && y==stop.y) return step;
	
	int xx,yy;
	int dir1 = (dir+1)%4;
	xx = x+dx[dir1], yy = y+dy[dir1];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir1,step+1);
	
	int dir2 = dir;
	xx = x+dx[dir2], yy = y+dy[dir2];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir2,step+1);
	
	int dir3 = (dir-1+4)%4;
	xx = x+dx[dir3], yy = y+dy[dir3];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir3,step+1);
	
	int dir4 = (dir+2)%4;
	xx = x+dx[dir4], yy = y+dy[dir4];
	if(s[xx][yy]!='#') return dfs_right(xx,yy,dir4,step+1);
}

int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		scanf("%d %d\n",&w,&h);
		for(int i=0;i<h;i++){
			for(int j=0;j<w;j++){
				scanf("%c",&s[i][j]);
				if(s[i][j]=='S'){
					start.x = i;
					start.y = j;
					start.step = 1;
					//printf("##%d %d\n",i,j);
				}
				if(s[i][j]=='E'){
					stop.x = i;
					stop.y = j;
					//printf("##%d %d\n",i,j);
				}
			}
			getchar();
		}
		int x  = start.x, y = start.y;
		for(int i=0;i<4;i++){
			int xx = x+dx[i], yy = y+dy[i];
			if(xx>=0 && xx<h && yy>=0 && yy<w && s[xx][yy]!='#'){
				start.dir = i;
				break;
			}
		}
		printf("%d %d %d\n",dfs_left(x,y,start.dir,1),dfs_right(x,y,start.dir,1),bfs());
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 1321 排兵布阵问题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值