6-6 带头结点的链式表操作集

本题要求实现带头结点的链式表操作集。

函数接口定义:
List MakeEmpty();
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef struct LNode *PtrToLNode;
struct LNode {
ElementType Data;
PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;

各个操作函数的定义为:

List MakeEmpty():创建并返回一个空的线性表;

Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;

bool Insert( List L, ElementType X, Position P ):将X插入在位置P指向的结点之前,返回true。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回false;

bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回false。

裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>

#define ERROR NULL
typedef enum {false, true} bool;
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode {
ElementType Data;
PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;

List MakeEmpty();
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

int main()
{
List L;
ElementType X;
Position P;
int N;
bool flag;
L = MakeEmpty();
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
flag = Insert(L, X, L->Next);
if ( flag= =false ) printf(“Wrong Answer\n”);
}
scanf("%d", &N);
while ( N-- ) {
scanf("%d", &X);
P = Find(L, X);
if ( P == ERROR )
printf(“Finding Error: %d is not in.\n”, X);
else {
flag = Delete(L, P);
printf("%d is found and deleted.\n", X);
if ( flag= =false )
printf(“Wrong Answer.\n”);
}
}
flag = Insert(L, X, NULL);
if ( flag= =false ) printf(“Wrong Answer\n”);
else
printf("%d is inserted as the last element.\n", X);
P = (Position)malloc(sizeof(struct LNode));
flag = Insert(L, X, P);
if ( flag==true ) printf(“Wrong Answer\n”);
flag = Delete(L, P);
if ( flag= =true ) printf(“Wrong Answer\n”);
for ( P=L->Next; P; P = P->Next ) printf("%d ", P->Data);
return 0;
}
/* 你的代码将被嵌在这里 */

输入样例:
6
12 2 4 87 10 2
4
2 12 87 5

输出样例:
2 is found and deleted.
12 is found and deleted.
87 is found and deleted.
Finding Error: 5 is not in.
5 is inserted as the last element.
Wrong Position for Insertion
Wrong Position for Deletion
10 4 2 5

本题是带头结点的单链表操作集合。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#define ERROR NULL
typedef enum {false, true} bool;
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode
{
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;

List MakeEmpty(); 
Position Find(List L,ElementType X);
bool Insert(List L,ElementType X,Position P);
bool Delete(List L,Position P);

int main()
{
    List L;
    ElementType X;
    Position P;
    int N;
    bool flag;
    L=MakeEmpty();
    scanf("%d",&N);
    while(N--) 
	{
        scanf("%d",&X);
        flag=Insert(L,X,L->Next);
        if(flag==false) 
		printf("Wrong Answer\n");
    }
    scanf("%d",&N);
    while(N--) 
	{
        scanf("%d",&X);
        P=Find(L,X);
        if(P==ERROR)
        printf("Finding Error: %d is not in.\n",X);
        else 
		{
            flag=Delete(L,P);
            printf("%d is found and deleted.\n",X);
            if (flag==false)
            printf("Wrong Answer.\n");
        }
    }
    flag=Insert(L,X,NULL);
    if(flag==false) 
	printf("Wrong Answer\n");
    else
    printf("%d is inserted as the last element.\n", X);
    P=(Position)malloc(sizeof(struct LNode));
    flag=Insert(L,X,P);
    if(flag==true) 
	printf("Wrong Answer\n");
    flag=Delete(L, P);
    if(flag==true) 
	printf("Wrong Answer\n");
    for(P=L->Next;P;P=P->Next) 
	printf("%d ",P->Data);
    return 0;
}

//对应本题的代码: 
List MakeEmpty()
{
	List L;
	L=(List)malloc(sizeof(struct LNode));//申请空间和节点 
	L->Next=NULL;
	return L;
}
Position Find(List L,ElementType X)
{
	PtrToLNode p;
	p=L->Next;//让指针指向下一个结点 
	while(p!=NULL&&p->Data!=X)//遍历寻找 
	{
		p=p->Next;
	}
	if(p!=NULL&&p->Data==X)//在p不为空的条件下如果p指向的Data=X的话 
	return p;
	else
	return ERROR;
}
bool Insert(List L,ElementType X,Position P)
{
	PtrToLNode p,e;
	p=L;//因为带头节点,所以直接让p==L,只看p->的下一个是否符合要求即可,不用再细分 
	while(p!=NULL&&p->Next!=P)
	{
		p=p->Next;
	}
	if(p!=NULL&&p->Next==P)//p指向的下一个是P 
	{
		e=(List)malloc(sizeof(struct LNode));
		e->Data=X;//申请并赋值 
		e->Next=P;
		p->Next=e;
		return true;
	}
	else
	{
		printf("Wrong Position for Insertion\n");
		return false;
	}
}
bool Delete(List L,Position P)
{
	PtrToLNode p,tmp;
	p=L;//一样 
	while(p!=NULL&&p->Next!=P)
	{
		p=p->Next;
	}
	if(p!=NULL&&p->Next==P)
	{
		tmp=p->Next;//指针指向相应位置 
		p->Next=tmp->Next;//让p->的下一个结点等于p指向的下一个结点的下一个 
		free(tmp);//释放空间 
		return true;
	}
	else
	{
		printf("Wrong Position for Deletion\n");
		return false;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值