浙江大学PAT_甲级_1083. List Grades (25)

题目链接:点击打开链接

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE
我的C++代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<array>
using namespace std;
int main()
{
	int i = 0, n = 0;//n学生人数
	int grade=0,mingrade = 0, maxgrade = 0;//mingrade最低分数线,maxgrade最高分数
	string name, ID;
	array<string,101> NameAndID;//数组以分数为下标用来存储姓名和ID
	NameAndID.fill("#");//姓名和ID全部设置为"#"
	cin >> n;
	for (i = 0; i < n; i++)
	{
		cin >>name >> ID >> grade;
		NameAndID[grade] = name + ' ' + ID;
	}
	cin >> mingrade >> maxgrade;
	for (i =maxgrade; i >=mingrade; i--)//从最高分到最低分输出姓名和ID
	{
		if (NameAndID[i] != "#")
		{
			cout << NameAndID[i] << endl;
			n = -1;
		}
	}
	if (n!=-1)//没有符合条件的人
	{
		cout << "NONE";
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
select csr.school_year 学年,csr.name 学期,cs.name 姓名,cs.code 学号,cs.grade 年级,cd.name 学院,cm.name 专业,ca.name 行政班,cj.lesson_no 课程号,tc.code 课程代码,tc.name 课程名称, listagg(ct.name,',') within group(order by ct.name) 授课教师, tc.credits 学分,cj.score_text 分数,cj.gp 绩点,xc.name 课程类别,xc.code 课程类别代码,hc.name 修读类别,xs.name 学生类别,pscj.score_text 平时成绩,qzcj.score_text 期中成绩, sycj.score_text 实验成绩,qmcj.score_text 期末成绩,zpcj.score_text 总评成绩,bkcj.score_text 补考成绩 from t_course_grades cj left join c_students cs on cs.id = cj.std_id left join c_semesters csr on csr.id = cj.semester_id left join t_courses tc on tc.id = cj.course_id left join c_departments cd on cd.id = cs.department_id left join c_majors cm on cm.id = cs.major_id left join c_adminclasses ca on ca.id = cs.adminclass_id left join xb_course_types xc on xc.id = cj.course_type_id left join hb_course_take_types hc on hc.id = cj.course_take_type_id left join xb_std_types xs on xs.id = cs.type_id left join t_lessons_teachers tlt on tlt.lesson_id=cj.lesson_id left join c_teachers ct on ct.id = tlt.teacher_id left join t_exam_grades bkcj on cj.id = bkcj.course_grade_id and bkcj.grade_type_id=4 left join t_exam_grades pscj on cj.id = pscj.course_grade_id and pscj.grade_type_id=3 left join t_exam_grades qzcj on cj.id = qzcj.course_grade_id and qzcj.grade_type_id=1 left join t_exam_grades zpcj on cj.id = zpcj.course_grade_id and zpcj.grade_type_id=7 left join t_exam_grades qmcj on cj.id = qmcj.course_grade_id and qmcj.grade_type_id=2 left join t_exam_grades sycj on cj.id = sycj.course_grade_id and sycj.grade_type_id=8 where cj.semester_id='243' and cs.code='21403186' order by cs.code
最新发布
06-07
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值