PAT甲级真题 1083 List Grades (25分) C++实现(简单数组排序)

题目

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:
Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

思路

建立结构体数组,遍历找出符合条件的加入新的数组。

对新的数组按年级排序后输出即可。

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct Stu{
    string name;
    string id;
    int grade;
};
bool cmp(Stu s1, Stu s2){
    return s1.grade > s2.grade;
}
int main(){
    int n;
    cin >> n;
    vector<Stu> S(n);
    for (int i=0; i<n; i++){
        cin >> S[i].name >> S[i].id >> S[i].grade;
    }
    int l, h;
    cin >> l >> h;
    vector<Stu> R;
    for (int i=0; i<n; i++){
        if (S[i].grade>=l && S[i].grade<=h){
            R.push_back(S[i]);
        }
    }
    if (R.size()==0){
        cout << "NONE" << endl;
    }
    else{
        sort(R.begin(), R.end(), cmp);
        for (int i=0; i<R.size(); i++){
            cout << R[i].name << " "  << R[i].id << endl;
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值