POJ Cellular Automaton

Description

cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell imodulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers nmd, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m− 1 — initial values of the automaton’s cells.

题意

给你一个“轮”:一个n个位置的环,每经过一次置换,每个位置的值会变成上一次周围d范围之内的和,即对于每一个a[i],更新a[i]= sum( a[j] ) % m,其中(min ( |i-j| ,n-|i-j| )<=d)。置换过k次后且mod m后每个位置的值。

输入第一行有四个整数分别为n、m、d、k。第二行有n个长整型的数,表示n个数的初始值。

输出n个数表示经过k次置换后,每个位置的值。

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output

sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

题解

这是一道比较特殊的矩阵快速幂。刘汝佳的《算法竞赛入门经典——训练指南》第156页有这题题目的详细翻译和思路的提示。核心是抓住循环矩阵的特点:只要记录第一行就可推出剩下的所有行。
开始我也不大理解,但是在lwh大神的指导下我明白了。细节见程序:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
int n,m,d,k;
ll a[502]/*循环矩阵*/,b[502]/*答案矩阵*/,num[502]/*数字数组*/;
void mul(ll A[502],ll B[502],ll C[502])
{
     ll t[502]={0};
     for(int i=0;i<n;i++) 
	 for(int j=0;j<n;j++)  
     {
         if(i-j>=0)  t[i]=(t[i]+(A[j]*B[i-j])%m)%m;
         else t[i]=(t[i]+(A[j]*B[i-j+n])%m)%m;
     }
     for(int i=0;i<n;i++)  C[i]=t[i];
}
void ksm(int cf)//因为循环矩阵的次方也是循环矩阵(可用暴力证明) 
{
	while(cf)
	   {if(cf&1) mul(b,a,b);
        cf=cf>>1;
        mul(a,a,a);
	   }
}
int main()
{
    scanf("%d%d%d%d",&n,&m,&d,&k);
    a[0]=1;
    for(int i=0;i<n;i++)  scanf("%lld",&num[i]);
    for(int i=1;i<=d;i++)  {a[i]=1;a[n-i]=1;}    
    b[0]=1;//答案矩阵初始化为1。 
    ksm(k);
    mul(num,b,num);
    for(int i=0;i<n-1;i++) 
	   printf("%lld ",num[i]);
	printf("%lld\n",num[n-1]);
   // system("pause");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值