建立ospf邻居路由

在这里插入图片描述
1.启动设备

进入两个路由器的接口配置ip地址及子网掩码

R1配置步骤:

system-view //进入系统视图

[Huawei]sysname R1 //改名字

[R1]interface GigabitEthernet 0/0/0 //进入接口GE0/0/0

[R1-GigabitEthernet0/0/0]ip address 12.1.1.1 24 //配置ip地址及子网掩码

[R1-GigabitEthernet0/0/0]undo shutdown //激活接口(华为默认是开启的,这里是我的习惯)

2.R2配置步骤:

system-view //进入系统视图

[Huawei]sysname R2 //改名为R2

[R2-GigabitEthernet0/0/0]IP address 12.1.1.2 24 //配置ip地址及子网掩码

[R2-GigabitEthernet0/0/0]int lo0

[R2-GigabitEthernet0/0/0]ip address 192.168.1.1 24 //配置环回口

[R2-GigabitEthernet0/0/0]UNDO shutdown 激活接口

ospf配置步骤

  • R1配置步骤

[R1-LoopBack0]ospf //进入ospf(不写进程标识的话,默认是 1 )

[R1-ospf-1]area 0 //进入区域0

[R1-ospf-1-area-0.0.0.0]network 12.1.1.1 0.0.0.0 //精确宣告12.1.1.1所在链路进入ospf 区域 0

  • R2配置步骤

[R2]interface LoopBack 0 //创建并进入虚拟接口loopback 0

[R2-LoopBack0]ospf //进入ospf(不写进程标识的话,默认是 1 )

[R2-ospf-1]area 0 //进入区域0

[R2-ospf-1-area-0.0.0.0]network 12.1.1.2 0.0.0.0 //精确宣告12.1.1.2所在链路进入ospf 区域 0

[R2-ospf-1-area-0.0.0.0]network 192.168.1.1 0.0.0.0 //精确宣告192.168.1.1的环回口

display ospf 1 peer brief //查看ospf邻居表的简要信息
在这里插入图片描述
在这里插入图片描述
确保最小范围内链路是互相 Ping通 的;(交换)

   R1:Ping R2 ;

   R2:Ping R1 ;

在这里插入图片描述

  • 1
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:数字20 设计师:CSDN官方博客 返回首页

打赏作者

Jiachang_001

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值