POJ - 3276/USACO - Mar07 Gold Face The Right Way 尺取法+反转

14 篇文章 0 订阅
11 篇文章 0 订阅

Description
Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input
Line 1: A single integer: N
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output
Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint
For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source
USACO 2007 March Gold

【题意】
N头牛排成一列1<=N<=5000。每头牛或者向前(表示为F)或者向后(表示为B)。为了让所有牛都面向前方,农夫每次可以将K头连续的牛转向1<=K<=N,求操作的最少次数M和对应的最小K。

思路:枚举所有的K,每个K都从最左端考虑每头牛的情况,若朝向后方则需要翻转,前方则不需要。但是该法的时间复杂度为O(N^3),因此需要优化。
优化的方法是:用f[i]记录[i,i+K-1]是否进行了翻转,是则为1,否则为0.
这样,当考虑第j头奶牛时,f[j-K+1]+f[j-K+2]+……+f[j-1]的和为奇数时则第j头奶牛的方向与初始方向相反,否则是没有变的。
运用尺取法时,可以用常数的时间求出f[j-K+1]+f[j-K+2]+……+f[j-1]的和sum.

/*
    Name: Face_The_Right_Way
    Copyright: Twitter & Instagram @stevebieberjr
    Author: @stevebieberjr
    Date: 29/07/16 08:51
*/
#include<cstdio>
#include<cstring>
#define maxn 5005
using namespace std;

int N,dir[maxn],f[maxn];
char ch;

int calc(int K)
{
    memset(f,0,sizeof(f));
    int res=0,sum=0;
    for(int i=0;i+K<=N;i++)
    {
        if((dir[i]+sum)%2!=0)
        {
            res++;
            f[i]=1;
        }
        sum+=f[i];
        if(i-K+1>=0)
        {
            sum-=f[i-K+1];
        }
    }

    for(int i=N-K+1;i<N;i++)
    {
        if((dir[i]+sum)%2!=0)
        {
            return -1;
        }
        if(i-K+1>=0)
        {
            sum-=f[i-K+1];
        }
    }
    return res;
}

void solve()
{
    int K=1,M=N;
    for(int k=1;k<=N;k++)
    {
        int m=calc(k);
        if(m>=0 && M>m)
        {
            M=m;
            K=k;
        }
    }
    printf("%d %d\n",K,M);
}

int main()
{
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        getchar();
        scanf("%c",&ch);
        if(ch=='F') dir[i]=0;
        if(ch=='B') dir[i]=1;
    }
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值