HDU - 2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20612    Accepted Submission(s): 9045


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 



很简单的题死活WA了好几次……首先是输入的x可能为浮点型,其次是函数是单调递增且有取值范围,超过最值则输出没有结果,最后是计算精度,虽然是保留4位但是还是要计算到1e-8以内……
#include <iostream>
#include<stdio.h>
#include<math.h>
using namespace std;

int main()
{
    int T;
    double x,y,z,l,h;
    cin>>T;
    while(T--){

        cin>>y;
        if(y<6||y>807020306){
            cout<<"No solution!"<<endl;
            continue;
        }
        x=50.0;
        h=100.0;
        l=0.0;
        while(fabs(h-l)>1e-8){
            z=8.0*x*x*x*x + 7.0*x*x*x + 2.0*x*x + 3.0*x + 6.0;
            if(z>y){
                h=x;
            }else{
                l=x;
            }
            x=(h+l)/2;
        }
        //printf("%.5lf\n",x);
        printf("%.4lf\n",x);

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值