Radar Installation POJ - 1328 贪心

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

在横坐标轴上放置雷达,每个雷达可扫描以雷达为圆心以d为半径的圆,要求扫描范围覆盖到所有的岛屿,求雷达最少个数。
逆向思考,求出每个岛屿要被扫描到,雷达在坐标轴上该放置到哪段区间内,将区间的右端点从小到大排序,再从左到右在右端点放置雷达,保证右边的区间尽量与上一个雷达接近,节省个数

#include <math.h>
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
int n;
double d;
struct node{
    double l,r;
}ma[1005];
double a[1005];
double b[1005];
bool cmp(node n1,node n2){
    return n1.l<n2.l;
}
int main()
{
    double t1,t2;
    int i,ca,flag;
    ca=1;
    while((scanf("%d %lf",&n,&d))!=EOF){
        if(n==0&&fabs(d-0)<1e-8)
            return 0;
        for(i=0;i<n;i++){
            scanf("%lf %lf",&t1,&t2);
            a[i]=t1;b[i]=t2;
        }
        flag=0;
        for(i=0;i<n;i++){
            if(b[i]>d){
                flag=1;
                break;
            }
            ma[i].r=a[i]+sqrt(d*d-b[i]*b[i]);
            ma[i].l=a[i]-sqrt(d*d-b[i]*b[i]);
        }
        printf("Case %d: ",ca);
        ca++;
        if(flag){
            printf("-1\n");
            continue;
        }
        sort(ma,ma+n,cmp);
        node t=ma[0];
        int cot=1;
        for(i=1;i<n;i++){
            if(ma[i].l>t.r){
                t=ma[i];
                cot++;
            }else if(ma[i].r<t.r){
                t=ma[i];
            }
        }
        printf("%d\n",cot);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值