1044 Shopping in Mars (25 分)(PAT (Advanced Level))

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.
Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1​⋯DN​ (Di​≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
结尾无空行

Sample Output 1:

1-5
4-6
7-8
11-11
结尾无空行

Sample Input 2:

5 13
2 4 5 7 9
结尾无空行

Sample Output 2:

2-4
4-5
结尾无空行
题目大意:
给定N个数,在N个数的序列中求满足条件的连续个数和=M的区间,按递增顺序输出每个满足的区间下标,如果没有满足条件的,输出满足=比M大的数的最小值区间下标。
思路:利用sum1数组存储前i项和,二重循环会超时,因此利用滑动窗口算法求解。

#include <bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
int N,M,a[100001],sum1[100001];
int main()
{  //freopen("in.txt","r",stdin);
    cin>>N>>M;
    int i,j,flag=0,minsum=inf;
    long long sumt=0;
    for(i=1;i<=N;i++)//数组sum1存放前i项和
      {cin>>a[i];
       sumt+=a[i];
       sum1[i]=sumt;
      }
      j=1; //指针j指向后一位
    for(i=0;i<N;i++)//从0开始  求满足和>=M的最小值
    {  
        while(sum1[j]-sum1[i]<M&&j<N)
        {
           j++;  //j向右滑动直到满足条件
        }
        if(sum1[j]-sum1[i]>=M) //如果满足条件
       minsum=min(minsum,sum1[j]-sum1[i]);//求最小值
    }
    j=1; //再次使用滑动窗口
    for(i=0;i<N;i++)
    {  
        while(sum1[j]-sum1[i]<M&&j<N)
        {
           j++;
        }
      if(sum1[j]-sum1[i]==minsum) //条件变为==最小值
      {  if(!flag)
        printf("%d-%d",i+1,j);//输出
         else
         printf("\n%d-%d",i+1,j);
        flag=1;  
      }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

乔梦圆的博客

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值