关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。
输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

思路:建堆,然后根据最小堆的定义,判断。
第一次全对代码:(虽然很多没有的代码,但是第一次独立做出来很开心)

#include<iostream>
using namespace std;
void siftup(int i);//向上调整建立堆 
int n,k;
int h[10001];
void print();
void swap(int x,int y);
void judge();
int work(string s);
int work2(string s);
int index(int x)
{
	int i;
	for(i=1;i<=n;i++)
		if(h[i]==x)
			return i;
}
int main ()
{
	int i,j,w;
	cin>>n>>k;
	for(i=1;i<=n;i++)
	{
		cin>>h[i];
		siftup(i);//向上调整建堆 
	} 
	judge();
	return 0;
}
void swap(int x,int y)
{
	int t;
	t=h[x];
	h[x]=h[y];
	h[y]=t;
}
void siftup(int i)//向上调整建立堆
{
	int t,flag=0;
	if(i==1) return ;
	while(i!=1&&flag==0)//不是根且父亲比孩子大
	{
		if(h[i]<h[i/2])
			swap(i,i/2);
		else flag=1;	
		i=i/2;
		
	 } 
	
}
void judge()
{
	getchar();
	int i;
	for(i=0;i<k;i++)
	{
		string s;
		getline(cin,s);
		if(s.find("root")!=string::npos){
			int num=work(s);
			if(num==h[1]) cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}else if(s.find("child")!=string::npos){
			int num1=work(s);
			int num2=work2(s);
		
			if(index(num1)/2==index(num2)) cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}else if(s.find("parent")!=string::npos){
			int num1=work(s);
			int num2=work2(s);
		
			if(index(num1)==index(num2)/2) cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}else{
			int num1=work(s);
			string temp=to_string(num1);
			int j,num2=0,flag=0;
			
			for(j=temp.length();j<s.length();j++)
			{
				if(isdigit(s[j]))
				{
					num2=num2*10+s[j]-'0';	
				}
				if(s[j]=='-')
				flag=1;
			}
			if(flag==1) num2=-num2;		
		//	cout<<num1<<" "<<num2<<endl;
			if(index(num1)/2==index(num2)/2) cout<<"T"<<endl;
			else cout<<"F"<<endl;
		}
	//	cout<<s<<endl;	
	}	
} 
int work(string s)
{
	int j;
		for(j=0;j<s.length();j++)
			if(s[j]==' ')
				break;
	string s1=s.substr(0,j);
	int num=stoi(s1);
	return num;
}
int work2(string s)
{
	int j;
	for(j=s.length()-1;j>=0;j--)
		if(s[j]==' ')
			break;
	string s1=s.substr(j+1,s.length());
	int num=stoi(s1);
	return num;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值