关于堆的判断 (小顶堆)

L2-3 关于堆的判断  

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N≤\le 1000)和M≤\le 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000][-10000, 10000][10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T


分析://主要是对字符串的分解过于繁琐,这一点我也表示很无语,开始还不知道怎么分解,也是从网上看到别人的解法,实在佩服

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<cstdlib>
#define INF 1000000
using namespace std;
int a[1010],n,m;
int insert(int i){
	int temp;
	while(a[i/2]>a[i] && i!=1){
		temp=a[i];
		a[i]=a[i/2];
		a[i/2]=temp;
		i=i/2;
	}
	return 0;
}
int find(int x){
	//找爸爸
	int p,i;
	for(i=1;i<=n;i++)
	{
		if(a[i]==x)
		p=i;
	}
	return a[p/2];
}
int panduan(){
	string str,str1,str2;
	int x,y;
	char ch;
	cin>>x>>str;
	if(str=="and"){
		cin>>y>>str1>>str2;
		if(find(x)==find(y))
		cout<<"T"<<endl;
		else
		cout<<"F"<<endl;
		return 0;
	}
	cin>>str;
	if(str=="a"){
		cin>>str1>>str2>>y;
		if(find(x)==y)
		cout<<"T"<<endl;
		else
		cout<<"F"<<endl;
		return 0;
	}
	cin>>str;
	if(str=="root"){
		if(a[1]==x)
		cout<<"T"<<endl;
		else
		cout<<"F"<<endl;
		return 0;
	}
	cin>>str1>>y;
	if(find(y)==x)
	cout<<"T"<<endl;
	else
	cout<<"F"<<endl;
	return 0;
}
int main(){
	cin>>n>>m;
	int i,j;
	cin>>a[1];
	for(i=2;i<=n;i++){
		cin>>a[i];
		insert(i);//除了第一个节点不用进行插入排序,余下节点都需要进行插入排序
	}
	while(m--){
		panduan();//对字符串进行对错判断
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值