[kuangbin]专题一 简单搜索 E - Find The Multiple

E - Find The Multiple

  POJ - 1426   

Description

a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple soluhem is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
11111111111111111

题意:找到一个数是n的倍数,且只能有0,1构成。本来还在想100超过long long 怎么搞。事实上不用想那么多 直接BFS就能过。DFS的话是到20层(long long 范围)。

ACcode:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int n;
long long bfs()
{
    queue<long long> q;
    q.push(1);
    while(!q.empty())
    {
       		long long p=q.front();
      		q.pop();
            q.push(p*10);
            if((p*10)%n==0) return (p*10);
            q.push(p*10+1);
            if((p*10+1)%n==0) return (p*10+1);
    }
    return 0; //一定要加,不加必WA 
}
int main()
{
    while(scanf("%d",&n)==1 &&n)
    printf("%lld\n",bfs());
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值