[kuangbin带你飞]专题一 简单搜索-E - Find The Multiple POJ - 1426

Find The Multiple

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

 

10100100100100100100111111111111111111

题解:

        题目的意思是,每次给出一个数字,我们要给出它的倍数,但是倍数只能是由0和1构成的十进制数。
        题目限制:     (1)给出的数字最多不超过200.
                            (2)保证答案在100位以内.
                            (3)有多种答案时,任意一组即可(Special judge)
        其实这道题目如果这样直接看一定是只能找规律的,因为他的位数太多了,100位的话深宽搜是一定会炸的。但是,如果我们静下心来,把数据给简单模拟一边,我们就会发现,其位数最多也只会有18位,也就是long long都可以直接储存了这样我们宽搜,深搜就会非常快了。
        打表法:如果我们实在没有能力去找到规律,那么我们就尝试的暴力去找找规律,最后我们找到的就是最高只有18位了。
ll ans[205] = {0,
1,10,111,100,10,1110,1001,1000,111111111,10,
11,11100,1001,10010,1110,10000,11101,1111111110,11001,100,
10101,110,110101,111000,100,10010,1101111111,100100,1101101,1110,
111011,100000,111111,111010,10010,11111111100,111,110010,10101,1000,
11111,101010,1101101,1100,1111111110,1101010,10011,1110000,1100001,100,
100011,100100,100011,11011111110,110,1001000,11001,11011010,11011111,11100,
100101,1110110,1111011111,1000000,10010,1111110,1101011,1110100,10000101,10010,
10011,111111111000,10001,1110,11100,1100100,1001,101010,10010011,10000,
1111111101,111110,101011,1010100,111010,11011010,11010111,11000,11010101,1111111110,
1001,11010100,10000011,100110,110010,11100000,11100001,11000010,111111111111111111,100,
101,1000110,11100001,1001000,101010,1000110,100010011,110111111100,1001010111,110,
111,10010000,1011011,110010,1101010,110110100,10101111111,110111110,100111011,111000,
11011,1001010,10001100111,11101100,1000,11110111110,11010011,10000000,100100001,10010,
101001,11111100,11101111,11010110,11011111110,11101000,10001,100001010,110110101,100100,
10011,100110,1001,1111111110000,11011010,100010,1100001,11100,110111,11100,
1110001,11001000,10111110111,10010,1110110,1010100,10101101011,100100110,100011,100000,
11101111,11111111010,1010111,1111100,1111110,1010110,11111011,10101000,10111101,111010,
1111011111,110110100,1011001101,110101110,100100,110000,100101111,110101010,11010111,11111111100,
1001111,10010,100101,110101000,1110,100000110,1001011,1001100,1010111010111,110010,
11101111,111000000,11001,111000010,101010,110000100,1101000101,1111111111111111110,111000011,1000,
};

这个数据当然不是这么好得的,我们还得用宽搜去模拟,最后发现规律。

宽搜的解法:
#include <iostream>
#include <queue>
using namespace std;

typedef long long ll;

int main()
{
    ios::sync_with_stdio(false);

    ll num;
    while (cin >> num,num){

        ll t = 1;
        queue<ll> qu;
        qu.push(t);

        ll k;
        while (!qu.empty()){
            k = qu.front();
            qu.pop();

            if (k % num == 0)break;

            qu.push(k*10);
            qu.push(k*10+1);
        }

        cout << k << endl;
    }
}

打表的解法就略过了

这道题,我们得到了更多的信息。在POJ上如果我们用了G++是可以AC的,但如果用了C++就TLE了

看到BFS的局限,那就是速度慢,但如果是DFS就无所畏惧了,G++和C++都可以,而且速度要快于BFS
附上大神代码
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
bool found;
void DFS(unsigned __int64 t ,int n,int k)
{
    if(found)
        return ;//如果已经发现了答案就没搜的必要了
    if(t%n==0)
    {//发现答案,输出,标记变量该true
        printf("%I64u\n",t);
        found=true;
        return ;
    }
    if(k==19)//到第19层,回溯
        return ;
    DFS(t*10,n,k+1);    //搜索×10
    DFS(t*10+1,n,k+1);    //搜索×10+1
}
int main()
{
    int n;
    while(cin>>n,n)
    {
        found=false;//标记变量,当为true代表搜到了题意第一的m
        DFS(1,n,0);    //从1开始搜n的倍数,第三个参数代表搜的层数,当到第19层时返回(因为第20层64位整数存不下)
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值