Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

[分析]
基础的二分法,但是因为平时lower_bound用的少,所以卡了很久,就是因为他返回值的特性。

返回第一个大于等于value的地址,如果全小于value则返回lenth+1的地址。
这个返回值非常难判断是返回了什么,所以一直被迷惑,就是因为之前老是返回0!!!

[代码]

#include<cstdio>
#include<cstring>
#include<set>
#include<algorithm>
typedef long long ll;
using namespace std;

ll a[555], b[555], c[555], d[250002];

int binary(int x,int cnt)
{
    int mid;
    int left = 0, right = cnt-1;
    while (left <= right)
    {
        mid = (left + right) >> 1;
        if (d[mid] > x)right = mid-1;
        else if (d[mid] < x)left = mid+1;
        else return 1;
    }
    return 0;
}


int main()
{
    ll l, n, m, kase = 0;
    while (scanf("%lld%lld%lld", &l, &n, &m) != EOF)
    {
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        memset(d, 0, sizeof(d));
        for (int i = 0; i < l; i++)
        {
            scanf("%lld", &a[i]);
        }
        for (int i = 0; i < n; i++)
        {
            scanf("%lld", &b[i]);
        }
        for (int i = 0; i < m; i++)
        {
            scanf("%lld", &c[i]);
        }
        int cnt = 0;
        for (int i = 0; i < l; i++)
        {
            for (int j = 0; j < n; j++)
            {
                d[cnt++] = a[i]+b[j];
            }
        }
        d[cnt] = 10000;
        sort(d, d + cnt);
        printf("Case %lld:\n", ++kase);
        int wen;
        scanf("%lld", &wen);
        for (int i = 0; i < wen; i++)
        {
            int x;
            scanf("%lld", &x);
            int flag = 0;
            for (int j = 0; j < m; j++)
            {
                //if (binary(x - c[j], cnt)) 
                if(*lower_bound(d,d+cnt,x-c[j])==x-c[j])
                {
                    flag = 1; goto out;
                }
            }
        out:;
            printf("%s\n", flag ? "YES" : "NO");
        }
    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值