The kth great number (优先队列)

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3

[分析]
优先队列做。
不断push数字,如果size>k就pop,保持队列里面是当前最大的k个数。
所以只要在Q的时候输出top就可以了。

需要注意的是不要使用priority_queue <int,vector<int>,greater<int>>q;实测会超时。
重载<号,时间124过的。

[代码]

#include<cstdio>
#include<queue>
#include<vector>
#include<functional>
using namespace std;

struct S
{
    int num;
    friend bool operator<(S aa,S bb)
    {
        return aa.num>bb.num;
    }
}node;

int main()
{
    int n,k,x;
    char a[5];
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        priority_queue<S>q;
        while(n--)
        {
            scanf("%s",a);
            if(a[0]=='I')
            {
                scanf("%d",&x);
                node.num=x;
                q.push(node);
                if(q.size()>k)q.pop();
            }
            else 
            {
                printf("%d\n",q.top());
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值