HDU - 1358 - Period(KMP的next数组)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

[分析]
字符串题目凡是涉及到前缀都要考虑一下KMP算法的Next数组。
举个例子
aabaabaabaab
010123456789
以上是next,next表示的是与前缀的相似程度
找到最后一个0的位置,就是周期的末尾。记为len;
如果某个next[i]%len==0,那么表示这个位置可以输出一次答案,因为这里多了一个周期。

[代码]

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 1234567;
int T, n, m;
int Next[maxn];
char s[maxn];

void GetNext(char t[], int lent)
{
    int i, j;
    i = 0;
    j = Next[0] = -1;
    while (i<lent)
    {
        while (j != -1 && t[i] != t[j])
            j = Next[j];
        Next[++i] = ++j;
    }
}

int main()
{
    int kase = 0;
    while (scanf("%d", &n) != EOF&&n)
    {
        scanf("%s", s);
        GetNext(s, n);
        printf("Test case #%d\n", ++kase);
        for (int i = 0; i <= n; i++)
        {
            int len = i - Next[i];
            if (i%len == 0 && i / len>1)
            {
                printf("%d %d\n", i, i / len);
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值