CSU - 1216 - 异或最大值(字典树)

给定一些数,求这些数中两个数的异或值最大的那个值

Input
多组数据。第一行为数字个数n,1 <= n <= 10 ^ 5。接下来n行每行一个32位有符号非负整数。

Output
任意两数最大异或值

Sample Input
3
3
7
9
Sample Output
14
Hint
[分析]
就是字典树,然后儿子只有0和1

[代码]

#include<cstdio>
#include<cstring>
#include<stack>
#include<algorithm>
using namespace std;
//对于字符串比较多的要统计个数的,map被卡的情况下,直接用字典树
//很多题都是要用到节点下标来表示某个字符串
const int maxn = 2e6 + 5;//如果是64MB可以开到2e6+5,尽量开大
int tree[maxn][2];//tree[i][j]表示节点i的第j个儿子的节点编号
bool flagg[maxn];//表示以该节点结尾是一个单词
int tot;//总节点数
void insert_(int x)
{
    stack<int>st;
    while (x)
    {
        st.push(x % 2);
        x >>= 1;
    }
    while (st.size() < 32)
    {
        st.push(0);
    }
    int  len = st.size();
    int root = 0;
    for (int i = 0; i<len; i++)
    {
        int id = st.top();
        st.pop();
        if (!tree[root][id]) tree[root][id] = ++tot;
        root = tree[root][id];
    }
    flagg[root] = true;
}
int find_(int x)//查询操作,按具体要求改动
{
    stack<int>st;
    while (x)
    {
        st.push((x + 1) % 2);
        x >>= 1;
    }
    while (st.size() < 32)
    {
        st.push(1);
    }
    int len = st.size();
    int root = 0;
    int ans = 0;
    for (int i = 0; i < len; i++)
    {
        int id = st.top();
        st.pop();
        //if (!tree[root][id])id == 1 ? 0 : 1;
        //root = tree[root][id];
        if (tree[root][id])
        {
            ans = ans * 2 + 1;
            root = tree[root][id];
        }
        else
        {
            ans = ans * 2;
            if (id == 1)id = 0;
            else id = 1;
            root = tree[root][id];
        }
    }
    return ans;
}
void clear()//最后清空,节省时间
{
    for (int i = 0; i <= tot; i++)
    {
        flagg[i] = false;
        for (int j = 0; j<10; j++)
            tree[i][j] = 0;
    }
    tot = 0;//RE有可能是这里的问题
}

int main()
{
    int n;
    while (scanf("%d", &n) != EOF)
    {
        int now;
        int ans = 0;
        clear();
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &now);
            ans = max(ans, find_(now));
            insert_(now);
        }
        printf("%d\n", ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值