poj 3255 求次短路路径

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output

450

题解:

某街区共有R条道路,N个路口。道路可以双向通行。问1号到N号路口的次短路长度是多少?次短路指的是比最短路长度长的次短的路径。问一条边可以经过多次。

代码:

#include <iostream>
#include <stdio.h>
#include <queue>
using namespace std;
typedef pair<int,int> P;
const int MAX_N=5e3+100;
const int INF =0x3f3f3f3f;
int N,R;
struct edge
{
    int to,cost;
};

vector<edge> G[MAX_N];

int dist[MAX_N];
int dist2[MAX_N];

void solve()
{
    priority_queue<P,vector<P>,greater<P> > que;
    fill(dist,dist+N,INF);
    fill(dist2,dist2+N,INF);
    dist[0]=0;
    que.push(P(0,0));

    while(!que.empty())
    {
        P p = que.top(); que.pop();
        int v = p.second,d = p.first;
        if(dist2[v]<d) continue;
        for(int i=0;i<G[v].size();i++)
        {
            edge &e = G[v][i];
            int d2 = d+e.cost;
            if(dist[e.to]>d2)
            {
                swap(dist[e.to],d2);
                que.push(P(dist[e.to],e.to));
            }
            if(dist2[e.to]>d2&&dist[e.to]<d2)
            {
                dist2[e.to]=d2;
                que.push(P(dist2[e.to],e.to));
            }
        }
    }
    printf("%d\n",dist2[N-1]);
}



int main()
{
    int from;
    while(cin>>N>>R)
    {
        edge now;
        for(int i=0;i<R;i++)
        {
            cin>>from>>now.to>>now.cost;
            from--;
            now.to--;
            G[from].push_back(now);
            swap(now.to,from);
            G[from].push_back(now);
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值