hdu 2588 欧拉函数的应用

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
3
1 1
10 2
10000 72

Sample Output
1
6
260

题解:

自己之前做过一道类似的。
在51nod 1040 求一个数的最大公约数之和
大致思路是
一个因子的贡献是gcd(n,i)=x
我们对这个式子进行一个简单的处理gcd(n/x,i/x)=1
也就是求phi(n/x)*x之和
枚举因子的时候可以做一个简单的优化,但是注意根号n不要计算两次。
此题的思路
题目要求的是gcd(x,n)>=m
参考51nod1040的思路,其实我们可知gcd(x,n)计算的出来一定是n的因子,假设gcd(x,n)=a,通过转换可得gcd(x/a,n/a)=1,转化为枚举n的因子,求phi(n/a)之和

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

int Euler(int n)
{
    if(n==1) return 1;
    int m=n;

    for(int i=2;i*i<=m;i++)
    {
        if(m%i==0)
        {
            n-=n/i;
            while(m%i==0)
                m/=i;
        }
    }
    if(m!=1)
    {
        n-=n/m;
    }
    return n;
}

int solve(int n,int m)
{
    int ans=0;
    for(int i=1;i*i<=n;i++)
    {
        if(n%i) continue;
        int tmp = n/i;
        if(i>=m)
        ans+=Euler(tmp);
        if(i!=tmp&&tmp>=m)
        {
            ans+=Euler(i);
        }
    }
    return ans;
}

int main()
{
    int T,p=0;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int sum = solve(n,m);
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值