O - GCD - Extreme (II)

Given the value of N, you will have to find the value of G. The definition of G is given below:
G =
i

G=0;
for(i=1;i<N;i++)
for(j=i+1;j<=N;j++)
{
G+=gcd(i,j);
}

/*Here gcd() is a function that finds
the greatest common divisor of the two
input numbers*/
Input
The input file contains at most 100 lines of inputs. Each line contains an integer N (1 < N < 4000001).
The meaning of N is given in the problem statement. Input is terminated by a line containing a single
zero.
Output
For each line of input produce one line of output. This line contains the value of G for the corresponding
N. The value of G will fit in a 64-bit signed integer.
Sample Input
10
100
200000
0
Sample Output
67
13015
143295493160

题解:

根据题意可以推得求的是1~n的与因子的最大公约数之和。
之前在51做过一道类似的,但是那是暴力枚举因子。
暴力枚举因子TLE了好几次,下次遇到因子一定要想到筛法啊。
T了几次之后,参考了别人。打表+前缀和优化

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX=4e6+10;
typedef long long LL;
LL phi[MAX];
LL f[MAX];
using namespace std;

void get_eular()
{
     int i,j;
     memset(phi,0,sizeof(phi));
     phi[1]=1;
     for(int i=2;i<MAX;i++)
        if(!phi[i])
     {
         for(j=i;j<MAX;j+=i)
         {
             if(!phi[j]) phi[j]=j;
             phi[j]=phi[j]/i*(i-1);
         }
     }
     return ;
}

void init()
{
    memset(f,0,sizeof(f));

    for(int i=1;i<MAX;i++)
        for(int j=i*2;j<MAX;j+=i)//筛法枚举因子
    {
         f[j]+=phi[j/i]*i;
    }

    for(int i=3;i<MAX;i++)//前缀和优化
    {
        f[i]+=f[i-1];
    }
}

int main()
{
    get_eular();
    init();

    LL N;
    while((scanf("%lld",&N)!=EOF)&&N)
    {
      printf("%lld\n",f[N]);
    }


    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值