HDU 1071 The area 定积分

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11041    Accepted Submission(s): 7808


Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
  
  
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
  
  
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 

Author
Ignatius.L


原题链接:点击

解题思路:求抛物线函数和直线函数的系数,然后用定积分求面积
设抛物线方程为 y=ax^2+b*x+c 又因为p1是顶点 所以 x1=-b/(2*a) 
得到    b=-2*a*x1     ----①
把x1和①代入方程
y1=a*x1^2-2*a*x1^2+c 得到  c=y1+a*x1^2     ----②
把p2和①和②代入方程
化简得  a=(y2-y1)/(x1-x2)^2
设直线方程为 y=kx+t
k=△y/△x=(y3-y2)/(x3-y2)
把p3代入直线方程得
t=y3-k*x3

面积的定积分为s=1/3*a*x^3+1/2*(b-k)*x^2+(c-t)*x

题目所求面积为s2-s1即把p2,p3代入s得到的值的差

代码:
#include <stdio.h>
int main()
{
	int T;
	double x1,x2,x3,y1,y2,y3,area1,area2,a,b,c,k,t;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf%lf",&x1,&y1);
		scanf("%lf%lf",&x2,&y2);
		scanf("%lf%lf",&x3,&y3);
		a=(y2-y1)/((x1-x2)*(x1-x2));
		b=-2*a*x1;
		c=y1-a*x1*x1-b*x1;
		k=(y3-y2)/(x3-x2);
		t=y3-x3*k;
		area1=a*x3*x3*x3/3.0+(b-k)*x3*x3/2.0+(c-t)*x3;
		area2=a*x2*x2*x2/3.0+(b-k)*x2*x2/2.0+(c-t)*x2;
		printf("%.2lf\n",area1-area2); 
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值