HDU 1443 Joseph

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3048 Accepted Submission(s): 1719

Problem Description
The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 

Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 

Sample Input
3
4
0
 

Sample Output
5
30

原题链接: 点我

题目大意:约瑟夫环,有k个好人和k个坏人 编号从1,2,3....2k,前k个为都为好人,后k个都为坏人,按照约瑟夫环的排除方法即每次从m个人中排除第n个人,求在能够满足在不排除一个好人的情况下排除所有坏人的最小的n

解题思路:打表+模拟约瑟夫环  因为数据k只从1-13所以一定要打表 不然会超时

重要的是模拟约瑟夫环

设每次排除的人的位置为p 人数为m,排除第n人

判断p的位置是否大于k 或者为0,每排除一次人数都减1

代码:

#include <stdio.h>
bool Joseph(int m,int n)
{
	int k=m/2,p=0;
	while(m>k)
	{
		p+=n%m;
		p=p%m;
		if(p>k)
		{
			p--;
			m--;
		}
		else if(p==0)
		{
			p=--m;
		}
		else return false;
	}
	return true;
}
int main()
{
	int ans[14],m;
	for(int t=1;t<=13;t++)
	{
		for(int t1=t+1;;t1++)
		{
			if(Joseph(t*2,t1))
			{
				ans[t]=t1;
				break;
			}
		}	
	}
	while(scanf("%d",&m)&&m)
	{
		printf("%d\n",ans[m]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值