HDU 5056 字符串处理

Boring count

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 694    Accepted Submission(s): 283


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 

Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 

Output
For each case, output a line contains the answer.
 

Sample Input
  
  
3 abc 1 abcabc 1 abcabc 2
 

Sample Output
  
  
6 15 21
 

Source
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5107  5106  5105  5103  5102 
 
   题意:  给定一个串,寻找符合要求的子串。要求为子串中出现字符的最大频数小于K
   题解: 需要计算分别以每个字母结尾的且每个字母出现的次数不超过k的字符串,我们设定一个初始位置s,然后用游标i从头到尾遍历字符串,使用map记录期间各个字母出现的次数,如果以s开头i结尾的字符串满足要求,则把结果增加i-s+1。否则的话向前移动s,不断维护map,直到s指向的字母与i相同,从而满足字符串条件,把结果增加i-s+1。

需要注意的是结果可能会超int,需要用long long。

  代码
  #include<stdio.h>
#include<string.h>
int main()
{
   int T,b,mark[28];
   char a[100005];
   scanf("%d",&T);
   while(T--)
      {
         scanf("%s%d",a,&b);
         int k=strlen(a);
         memset(mark,0,sizeof(mark));
         __int64 num=0;
         int tou=0;
         for(int i=0;i<k;i++)
           {
              int k=a[i]-'a';
              if(mark[k]+1<=b)  
                {
                  mark[k]++;              
                  num+=(i-tou+1);
                }    
              else 
                {
                 while(a[tou]!=a[i])
                  {
                     mark[a[tou]-'a']--;
                     tou++;                 
                  }  
                 tou++;
                 num+=(i-tou+1);
                }
           }  
          printf("%I64d\n",num);  
      }   
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值