POJ 3278 Catch That Cow

11 篇文章 0 订阅
6 篇文章 0 订阅
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 62404 Accepted: 19533

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题目大意 有一个人在找自己的奶牛,他和奶牛在一条直线的路上,他的位置是N奶牛的位置是K,他每分钟可以进行一个操作,1.向前走一步,2.向后走一步,3.往前面跳到自己当前位置两倍的位置,问最少多分钟找到自己的奶牛。


思路 裸BFS


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
#define inf 0xffffff
#define maxn 100005

int Map[maxn];
int q[maxn],t1,t2;

int main()
{
    int s,e,ans;
    while(cin>>s>>e){
        memset(Map,0,sizeof(Map));
        t1 = t2 = 0;
        q[t2++] = s;
        Map[s] = 1;
        while(s != e){
            s = q[t1++];
            if(s*2 < maxn && !Map[s*2]) {Map[s*2] = Map[s] + 1; q[t2++] = s * 2;}
            if(s+1 < maxn && !Map[s+1]) {Map[s+1] = Map[s] + 1; q[t2++] = s + 1;}
            if(s-1 >= 0 && !Map[s-1]) {Map[s-1] = Map[s] + 1; q[t2++] = s - 1;}
        }
        cout<<Map[e] - 1<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值