1096. Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format “factor[1]factor[2]…*factor[k]”, where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

题目大意:

题目要求找出一个正整数的最长最小连乘子列,注意到长度的优先级大于数字的大小,例如对于题目给出的630,能找到的最小子列是5*6*7,而对于633,能找到的则是3(另一个是211,3<211且长度均为1,故选择3)。

思路:

很简单的暴力算法,只有一点需要注意的地方,就是一个一个正整数n不可能被比根号n大的数整除,所以循环可以缩短为2~sqrt(n)

代码:

#include<iostream>
#include<cmath>
using namespace std;
int main() {
    int n,i,j,ans,max=0;
    scanf("%d",&n);
    int t = sqrt(n);
    for(i=2;i<=t;i++) {
        int count = 0;
        int s = i;
        int temp = n;
        while(temp%s == 0) {
            count++;
            temp = temp/s;
            s++;
        }
        if(count>max) {
            max = count;
            ans = i;
        }
    }
    if(max == 0) {
        printf("1\n%d",n);
        return 0;
    } 
    printf("%d\n%d",max,ans);
    for(i=1;i<max;i++) {
        printf("*%d",ans+i);
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值