1099. Build A Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
这里写图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42

题目大意:

就是给你一棵节点数为n的搜索二叉树的框架和n个数字,让你把这几个数字填入框架中,使这棵树成为一棵搜索二叉树。

思路:

根据搜索二叉树的性质可知,其中序遍历的结果是递增的,我们可以把每个节点的标号用中序遍历的方法储存在中序遍历数组“in”中,如例子所示的话是“2,1,3,5,4,0,7,8,6”,然后将给的“key”值按从小到大排序,可得“11,25,38,42,45,58,67,73,82”,由此就可知道标号为“2”的节点的“key”值是“11”,标号为“1”的节点的“key”值是“25”,以此类推,可以把这种对应关系用一个“map”储存,然后按照层序遍历输出。

代码:

#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<queue>
using namespace std;
struct node {
    int data;
    int left;
    int right;
};
vector<node> mm;
vector<int> in,past,level;
void inorder(int r) {
    if(mm[r].left!=-1) {
        inorder(mm[r].left);    
    }
    in.push_back(r);
    if(mm[r].right!=-1) {
        inorder(mm[r].right);
    }
}
void levelq(int r) {
    queue<int> q;
    q.push(r);
    while(!q.empty()) {
        int temp=q.front();
        level.push_back(temp);
        q.pop();
        if(mm[temp].left!=-1) q.push(mm[temp].left);
        if(mm[temp].right!=-1) q.push(mm[temp].right);  
    }
}
int main() {
    int n,i,j;
    map<int,int> tmap;
    scanf("%d",&n);
    mm.resize(n);
    past.resize(n);
    for(i=0;i<n;i++) {
        int a,b;
        scanf("%d%d",&a,&b);
        mm[i].left=a;
        mm[i].right=b;
    }
    for(i=0;i<n;i++) {
        scanf("%d",&past[i]);
    }
    sort(past.begin(),past.end());
    inorder(0);
    for(i=0;i<n;i++) {
        tmap[in[i]]=past[i];
    }
    levelq(0);
    printf("%d",tmap[level[0]]);
    for(i=1;i<n;i++) {
        printf(" %d",tmap[level[i]]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值