Trailing Zeroes (III)(n!后有多少零+二分)

                                      Trailing Zeroes (III)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

n!中零的个数等于5出现的次数

n!=1*2*3*4*5*6*7*8*9*10*..........*n

=1*2*3*4*5**6*7*8*9*(2*5)*....*(3*5)....*n;

每出现一次五结果末尾会增加一个零

所以只需找出n!中有多少5的倍数就行了

#include <stdio.h>  
long long judge(long long x) //找有多少数是5的倍数
{  
    long long cnt=0;  
    while(x)  
    {  
        cnt=cnt+x/5;  
        x=x/5;  
    }  
    return cnt;  
}  
int main()  
{  
    int t;  
    scanf("%d",&t);  
    int cnt=1;  
    while(t--)  
    {  
        long long q;  
        scanf("%lld",&q);  
        long long l=0,r=500000000;   
        long long mid;  
        long long ans;  
        while(r>=l)  //二分查找
        {  
            mid=(l+r)/2;  
            if(judge(mid)>=q)  
            {  
                ans=mid;  
                r=mid-1;  
            }  
            else  
            {  
                l=mid+1;  
            }  
        }  
        if(judge(ans)!=q)   
        {  
            printf("Case %d: impossible\n",cnt);  
            cnt++;  
        }  
        else  
        {  
            printf("Case %d: %lld\n",cnt,ans);  
            cnt++;  
        }  
    }  
    return 0;  
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值