Trailing Zeroes (III) (数学)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible


【题意】输入一个数,表示阶乘值末尾0的个数,求满足条件的最小数。

  这道题的关键在于怎么知道一个数阶乘值末尾0的个数,因为数据庞大,不可能正常计算出来,所以就要采取一定的数学方法,经过尝试可以知道,1~4的阶乘值末尾没有0,5~9的阶乘值末尾一个0,10~14的阶乘值末尾2个0,但是!!!末尾三个0的数没有,所以用而二分就可以找出这样的数,具体看代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long LL;

LL ans(LL n)
{
    LL ss=0;
    while(n)
    {
        ss+=n/5;
        n/=5;
    }
    return ss;
}
int main()
{
    int t;
    LL m,a;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        scanf("%lld",&m);
        LL l=1,r=1e12;
        a=0;
        while(r>=l)
        {
            LL mid=(l+r)>>1;
            if(ans(mid)==m)
            {
                a=mid;
                r=mid-1;
            }
            else if(ans(mid)>m)
                r=mid-1;
            else
                l=mid+1;
        }
        if(a)
        printf("Case %d: %lld\n",i,a);
        else
            printf("Case %d: impossible\n",i);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值