【字符串Hash】HDU 1800 Flying to the Mars

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22996    Accepted Submission(s): 7365


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 
Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 
Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
 
 
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
 
 
1 2
 

Author
PPF@JLU
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1075 1671 1052 1251 1050 


 Problem Idea

【题意】

 题意为:我们假设一名士兵有一个等级编号表示他的学位。高一级的士兵可以教低一级,也就是说前者的水平>后者的水平。但低级不能教高等级。一名士兵最多只能有一名教师,当然,没有教师也是合法的。同样,一名士兵最多只能有一名学生,而没有学生也是可以的。老师可以用同一把扫帚教他的学生。当然,所有的士兵在飞向火星之前一定是练过扫帚的!魔术扫帚价格昂贵!那么,你能帮助PPF计算所需扫帚杆的最小数量吗?
例如 :
有5名士兵(A B C D E),级别编号:2 4 5 6 4;
一种方法:
C可以教B; B可以教A;所以,A B C有资格在同一把扫帚上学习。
D可以教E;因此D E有资格在同一把扫帚上学习;
使用这种方法,我们需要2把扫帚。
另一种方法:
D可以教A;所以A D有资格在同一把扫帚上学习。
C可以教B;所以B C有资格在同一把扫帚上学习。
E没有老师或学生有资格在一把扫帚上学习。
使用这种方法,我们需要3把扫帚。
在检查了所有可能的方法后,我们发现2是所需的最低数量的扫帚。

 【类型】
  Hash
 【分析】

  Hash模板题,入门。

 

   AC Souce Code

#include <iostream>
#include<cstring>
using namespace std;
const int N=7003;
const int MOD=7003;
int Hash[N],num[N];
int res;


unsigned int ELFHash(char *key){
	unsigned int hash=0;
	unsigned int x=0;
	
	while(*key){
		hash=(hash<<4)+*key;
		if((x=hash&0xf0000000L)!=0){
			hash^=x>>24;
			hash&=~x; 
		}
		key++;
	}
	return (hash&0x7fffffff);
} 

void hash_table(char *key){//线性探查法 
	
	int k=ELFHash(key);
	int t=k%MOD;
	while(Hash[t]!=k&&Hash[t]!=-1){
		t=(t+1)%MOD;
	}
	if(Hash[t]==-1){
		num[t]=1;
		Hash[t]=k;
	}
	else{
		res=max(res,++num[t]);
	}
}

int main(int argc, char** argv) {
	
	int n;
	char str[100];
	while(cin>>n){
		getchar();
		res=1;
		memset(Hash,-1,sizeof(Hash));
		for(int i=1;i<=n;i++){
			scanf("%s",str);
			int j=0;
			while(str[j] == '0') j++;//Attention!
			hash_table(str+j);
		}
		printf("%d\n",res);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值