PAT-A 1050 String Subtraction (20)(20 分)字符串含空格+哈希

https://pintia.cn/problem-sets/994805342720868352/problems/994805429018673152

1050 String Subtraction (20)(20 分)

Given two strings S~1~ and S~2~, S = S~1~ - S~2~ is defined to be the remaining string after taking all the characters in S~2~ from S~1~. Your task is simply to calculate S~1~ - S~2~ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S~1~ and S~2~, respectively. The string lengths of both strings are no more than 10^4^. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S~1~ - S~2~ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

 

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int nmax=1e4+10;
char s1[nmax];
int hashtable[nmax];
 
 
int main(int argc, char** argv) {
    while(cin.getline(s1,nmax)){
    	memset(hashtable,0,sizeof(hashtable));
    	int len1=strlen(s1);
    	while(true){
    		char c=getchar();
    		if(c=='\n') break;
    		hashtable[c]=1;
		}
		for(int i=0;i<len1;i++){
			if(hashtable[s1[i]]==0){
			   cout<<s1[i]; 
			} 
		}
        
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值