hdoj 1004

该博客介绍了一个关于计数颜色的问题,其中涉及到了C++编程中的迭代器使用。作者通过一个简单的竞赛场景,即计算不同颜色气球的数量,来阐述如何利用迭代器在地图容器中有效地进行计数和查找最频繁出现的颜色。博客内容包括输入输出格式、代码实现以及迭代器在计数过程中的作用。虽然作者起初没有理解为何要使用迭代器,但经过研究后发现它能方便地遍历并更新容器中的元素,从而解决了问题。
摘要由CSDN通过智能技术生成

Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题目大意就是对颜色计数

很简单 就可以想到用map
map<string,int> a;

#include <iostream>
#include <map>
#include <cstring>
#include <limits.h>
using namespace std;

map<string,int> a;
string temp;
int main(){
    int n;
    while(true){
        int maxn=INT_MIN;
        cin>>n;if(n==0) break;
        for(int i=1;i<=n;i++){
            long long maxn=INT_MIN;
            string s;
            cin>>s;
            a[s]++;
        }
        map<string,int>::iterator id;
        for(id=a.begin();id!=a.end();id++){
            if(id->second>maxn){
                maxn=id->second;
                temp=id->first;
           }
        }
        cout<<temp<<endl;
        a.clear();
    }
    return 0;
}

至于为什么用迭代器来计数 我也没整明白
一开始我是直接判断最大的位置 结果过不去
后来查了一下就用了迭代器访问容器
哎 烦死

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值