杭电1048——The Hardest Problem Ever(字符串)

问题描述

Problem Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
You are a sub captain of Caesar’s army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is ‘A’, the cipher text would be ‘F’). Since you are creating plain text out of Caesar’s messages, you will do the opposite:

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, “START”

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, “END”

Following the final data set will be a single line, “ENDOFINPUT”.

Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input
START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

问题分析

字符串处理问题,题设中规定输入的字符只能是大写字母或者空格,所以,就简化了处理。大致的算法如下:

if(c>='A'&&c<='E')
    c=c-5+26;
else if(c>='F'&&c<='z')
    c=c-5;

另外注意输入中有空格,scanf(“%s”,….)不能用~

AC代码

# include<stdio.h>
# include<string.h>

void cgetline(char *a);

int main()
{
    char data[255];
    int i;
    while(1)
    {
        cgetline(data);
        if(strcmp(data,"ENDOFINPUT")==0)
            break;
        else
        {
            memset(data,0,sizeof(char)*255);
            cgetline(data);
            for(i=0;i<strlen(data);i++)
            {
                if(data[i]>='A'&&data[i]<='E')
                    printf("%c",data[i]+21);
                else if(data[i]>='F'&&data[i]<='Z')
                    printf("%c",data[i]-5);
                else 
                    printf("%c",data[i]);
            }
            printf("\n");
            cgetline(data);
        }
    }
    return 0;
}

void cgetline(char *a)
{
    char ch;
    int i=0;
    while(scanf("%c",&ch)==1&&ch!='\n')
    {
        a[i++]=ch;
    }
    a[i]='\0';
}
Sure, I understand your question. Here's my response: The task at hand is to implement the overlap-add block convolution method in MATLAB. This method can be used to convolve a long input signal with a filter, by breaking the input signal into smaller blocks, convolving each block with the filter, and then adding the results together. The key advantage of this method is that it reduces the amount of computation required, compared to directly convolving the entire signal with the filter. To implement this method, we first need to define a function in MATLAB that takes as input an impulse response h, a data vector x, and a block length L. Here's the function definition: ``` function y = oafilt(h, x, L) ``` Once we have defined our function, we can use it to perform the overlap-add block convolution. Here's how we can do it: 1. Break the input signal x into smaller blocks of length L. ``` num_blocks = ceil(length(x) / L); x_blocks = zeros(L, num_blocks); for i = 1:num_blocks start_index = (i-1)*L + 1; end_index = min(i*L, length(x)); x_blocks(1:end_index-start_index+1, i) = x(start_index:end_index); end ``` 2. Pad the impulse response h with zeros, so that its length is at least L. ``` h_padded = [h; zeros(L-length(h), 1)]; ``` 3. Convolve each block of x with the padded filter h_padded, using the built-in conv function. ``` y_blocks = zeros(L+length(h)-1, num_blocks); for i = 1:num_blocks y_blocks(:, i) = conv(x_blocks(:, i), h_padded); end ``` 4. Add up the overlapping portions of the blocks to obtain the final output signal y. ``` y = zeros(length(x) + length(h) - 1, 1); for i = 1:num_blocks start_index = (i-1)*L; end_index = (i-1)*L + length(h) - 1; y(start_index+1:end_index+1) = y(start_index+1:end_index+1) + y_blocks(:, i); end ``` We can now use this function to redo Part (c) of the Lab 5 problem, which involves convolving a long signal with a filter. Here's how we can do it: ``` load('lab5_data.mat'); L = 512; y_oafilt = oafilt(h, x, L); y_conv = conv(h, x); y_conv = y_conv(1:length(y_oafilt)); max_diff = max(abs(y_oafilt - y_conv)); disp(['Maximum difference between overlap-add and conv: ' num2str(max_diff)]); ``` This code loads the data from the provided file, sets the block length L to 512, and then calls our oafilt function to perform the overlap-add convolution. We also use the built-in conv function to perform the convolution directly, and compare the results to make sure they are the same. The maximum difference between the two results is printed to the console. I hope this answers your question! Let me know if you have any further questions or concerns.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值