使用双向链表的形式完成:Reversing Linked List

本题其实考察额是链表的游标实现

Reversing Linked List

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
数据结构双向链表,并建立一个足够长的数组

#define MAX_ARRAY_SIZE 100000

typedef  int ElementType;
typedef  int NextIndex;
typedef int PreIndex;

struct Node
{
    ElementType Data;
    NextIndex Next;
    PreIndex Pre=-1000;
} List[MAX_ARRAY_SIZE];
伪代码
int main()
{
    //1.输入数据,构建链表

    //2.遍历构建前指针,并且记录链表的长度


    //3.通过双向链表和k值置换链表
}
Coding
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;


#define MAX_ARRAY_SIZE 100000

typedef  int ElementType;
typedef  int NextIndex;
typedef int PreIndex;

struct Node
{
    ElementType Data;
    NextIndex Next;
    PreIndex Pre=-1000;
} List[MAX_ARRAY_SIZE];



void printArr(int Root)
{
    cout << Root <<" "<< List[Root].Data << " "<< List[Root].Next<<endl;
    if (List[Root].Next != -1) {
        printArr(List[Root].Next);
    }
}

/*

00100 6 3
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
*/

void printArrAll(int Root)
{


    cout<<"~~  " << List[Root].Pre<<" - " << Root << "-" << List[Root].Data << "-" << List[Root].Next << endl;
    if (List[Root].Next != -1) {
        printArrAll(List[Root].Next);
    }
}



int translation(int currentIndex,int K) {
    int i = 1;
    while (i<K) {
        currentIndex = List[currentIndex].Next;
        i++;
    }
    return currentIndex;
}

void PrintPre(int address,int K, int tmpHead) {

    for (int i=0;i<K;i++) {
        if(i==K-1)
            cout << address << " " << List[address].Data << " " << tmpHead << endl;
        else
            cout << address << " " << List[address].Data << " " << List[address].Pre << endl;

        address = List[address].Pre;

        if (address == -1)
            break;
    }

}

int main()
{
    int RootAddress, N, K;
    cin >> RootAddress >> N >> K;

    int address;
    for (int i = 0; i < N; i++)
    {
        cin >> address;
        cin >> List[address].Data >> List[address].Next;
    }


    int NextIndex = List[RootAddress].Next;
    int PreIndex = List[RootAddress].Pre = -1;//pre是-1 代表他是根节点
    int Pre = RootAddress;

    int cnt = 1;


    while (NextIndex != -1) {

        List[NextIndex].Pre = Pre;
        Pre = NextIndex;

        NextIndex = List[NextIndex].Next;
        cnt++;

    }

    printArrAll(RootAddress);
    cout << "-------------" << endl;


    cout << "长度: " << cnt << endl;
    //K
    cout << "-------------" << endl;
    int count = N / K;

    bool isMore = count * K < N;

    int index = RootAddress;
    int nextIndex;
    for (int i = 0; i < count; i++)
    {
        if (i == 0)
            index = translation(index, K);
        else
            index = nextIndex;


        if(i<count-1)
            nextIndex = translation(index, K+1);
        else
            nextIndex = List[index].Next;

        PrintPre(index, K, nextIndex);

        if (nextIndex == -1)
            break;
    }

    if (isMore) {
        printArr(nextIndex);
    }

    system("pause");

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值