A Knight's Journey 深搜

A Knight's Journey

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 8
Problem Description
Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
 

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
 

Sample Input
  
  
3 1 1 2 3 4 3
 

Sample Output
  
  
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
 
#include<stdio.h>
#include<string.h>


int times;
struct node
{
int xx,yy;
}local[677];
int dirx[]={-2,-2,-1,-1,1,1,2,2},diry[]={-1,1,-2,2,-2,2,-1,1};


void chushihua(bool map[][27],int yy,int xx)
{
for(int i=1;i<=yy;i++)
for(int j=1;j<=xx;j++)
map[i][j]=true;
}


void DFS(bool map[][27],int &yy,int &xx,int y,int x)
{


map[y][x]=false;
local[times].xx=x;
local[times].yy=y;


times++;
for(int i=0;i<8;i++)
{
int xxx=x+dirx[i];
int yyy=y+diry[i];
if(xxx>0&&xxx<=xx&&yyy>0&&yyy<=yy&&map[yyy][xxx]==true)
{
DFS(map,yy,xx,yyy,xxx);

if(times==xx*yy+1)
return;
times--;
map[yyy][xxx]=true;
}


}


}
int main()
{
int n,xx,yy,kk;
bool map[27][27];
scanf("%d",&n);
    kk=n;
for(kk=1;kk<=n;kk++)
{
scanf("%d%d",&yy,&xx);
chushihua(map,yy,xx);
times=1;
DFS(map,yy,xx,1,1);
if(kk!=1)
putchar(10);
printf("Scenario #%d:\n",kk);


    if(times==yy*xx+1)
{
    for(int i=1;i<times;i++)
{
printf("%c%d",local[i].xx+'A'-1,local[i].yy);
}
putchar(10);

else
puts("impossible");


}




}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值