487-3279C语言

题目描述

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

输入

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

输出

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

样例输入

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

样例输出

310-1010 2
487-3279 4
888-4567 3
//用二维数组telNumbers[100000][9]存储全部电话号码的标准表示。每读入一个电话号码,先转换成标准格式,然后存储到二维数组中。全部电话号码输入完后,用函数模板qsort进行排序,用函数strcmp比较telNumbers中相邻号码,判断是否有重复的电话号码、并计算重复次数。
//用字符串map表示从电话拨号盘的字母到数字的映射关系:map[j]表示字母j+‘A’映射成的数字。
// char map[] = "22233344455566677778889999";
//使用C/C++的函数:qsort排序;strcmp比较。需要头文件stdlib.h 。qsort用 法:void qsort(void*, size_t, size_t,int (*)(const void*, const void*));
//对程序进行模块化和使用全局变量,号码标准化用函数standardizeTel,数组map和telNumbers作为全局变量。
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char map[]={"22233344455566677778889999"};
char str[80],Num[100000][9];
int compare(const void *elem1,const void *elem2)
{
	return(strcmp((char*)elem1,(char*)elem2));
}
void Tel(int n)
{
	int j,k;
	j=k=-1;
	while(k<8)
	{
		j++;
		if(str[j]=='-') continue;
		k++;
		if(k==3)
		{
			Num[n][k]='-';k++;
		}
		if(str[j]>='A'&&str[j]<='Z')
		{
			Num[n][k]=map[str[j]-'A']; continue;
		}
		Num[n][k]=str[j];
	}
	Num[n][k]='\0';
}
int main()
{
	int n,i,j;
	int nod;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%s",str);
		Tel(i);
	}
	qsort(Num,n,9,compare);
	nod=1;i=0;
	while(i<n)
	{
		j=i;i++;
		while(i<n&&strcmp(Num[i],Num[j])==0) i++;
		if(i-j>1)
		{
			printf("%s %d\n",Num[j],i-j);
			nod=0;
		}
	}
	if(nod) printf("No duplicates.\n");
	return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值