Maya CalendarC语言

题目描述

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal...

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, ..., where the number 0 was the beginning of the world. Thus, the first day was:

Haab: 0. pop 0

Tzolkin: 1 imix 0

Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

输入

The date in Haab is given in the following format:

NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

输出

The date in Tzolkin should be in the following format:

Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

样例输入

3
10. zac 0
0. pop 0
10. zac 1995

样例输出

3
3 chuen 0
1 imix 0
9 cimi 2801
//Haab历每年365天,19个月用0~18表示。前18个月20天,第19个月有5天,19个月的名字用不同字串表示,日期从0开始。通过月份*20+日期+1计算某个月的某一天是当年的第几天。
//Tzolkin历一年有260天,每个日期由数字和字符串组成。数字从1~13,字符串有20个不同的字符串,两个部分彼此独立。对于一年中某一天,可分别求出数字和字符串部分,然后组合。
//首先计算Haab历表示的日期是世界开始后的第几天(假设是k),然后用k除以260得到Tzolkin历的年份,再用k对260取模得到m,用m分别对13和20取模得到d和s,d和Tzolkin历中第s个字符串的组合就是要求的日期。
//注意:如果把世界的第1天用0表示,第260天用259表示,则用k除以260得到Tzolkin历的年份,m对13取模后得到0到12的值,这个值要加1才能用于表示Tzolkin历的日期,同时m对20取模后得到0~19的数值,分别表示取20个字符串中的一个。
#include<stdio.h>
#include<string.h>
const int NAMELEN=10;
char month1[19][10]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};	//Haab历月份
char month2[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok","chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};	//Tzolkin历
int main()
{
	int n,i,m;
	scanf("%d",&n);
	printf("%d\n",n);
	for(i=0;i<n;i++)
	{
		
		int day,year,dates;
		char month[NAMELEN];
		scanf("%d. %s %d",&day,month,&year);
		for(m=0;m<19;m++)
			if(!strcmp(month1[m],month)) break;
		dates=year*365+m*20+day;
		printf("%d %s %d\n",1+dates%13,month2[dates%20],dates/260);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Maya Mel语言是一种专门用于Maya软件的脚本语言。学习Maya Mel语言对于想要成为Maya软件高级用户或Maya脚本开发人员的人来说是非常有用的。 学习Maya Mel语言有以下几个方面的好处: 1. 自定义工作流程:Maya Mel语言可以让用户自定义Maya软件的工作流程。通过编写脚本,用户可以创建自己的工具或插件,以提高工作效率和简化重复性的任务,例如自动化模型的布线或批处理材质的创建。 2. 扩展Maya功能:Maya Mel语言可以帮助用户扩展Maya软件的功能。通过编写脚本,用户可以创建新的功能或修改现有的功能,以满足特定项目的需求。 3. 与Maya软件的紧密集成:Maya Mel语言Maya软件的内建脚本语言,因此与Maya软件的集成非常紧密。通过学习Maya Mel语言,用户可以更好地理解Maya软件的内部工作原理,更加灵活地利用Maya软件的功能。 学习Maya Mel语言有几个途径: 1. 官方文档和教程:Autodesk官方提供了详细的Maya Mel语言文档和教程,可以通过阅读官方文档和教程来学习Maya Mel语言的语法和使用方法。 2. 在线资源:互联网上有许多Maya Mel语言的学习资源,包括视频教程、博客文章和论坛讨论等。这些资源可以帮助用户深入了解Maya Mel语言的应用。 3. 实践和项目经验:通过实际项目的经验,用户可以更好地学习和理解Maya Mel语言的应用。通过从事Maya脚本开发或参与Maya项目,用户可以锻炼和提升Maya Mel编程的技能。 总的来说,学习Maya Mel语言对于想要深入使用Maya软件的人来说是非常重要的。通过学习Maya Mel语言,用户可以定制和扩展Maya的功能,提高工作效率,并在Maya项目中展示自己的技术能力。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值